Product images displaying incorrectly, or not rendering
Incident Report for Forbes Professional
Resolved
This issue has not been resolved and was due to a temporary issue with our CDN provider.
Posted Jun 04, 2020 - 11:28 BST
Identified
We're currently experiencing issues without product images not displaying correctly. We've identified the issue with our CDN provider and are quickly working on a fix.
Posted Jun 04, 2020 - 11:24 BST
This incident affected: forbespro.co.uk.